PDA

View Full Version : Problem with running Quake2 server



-=Hitman=-
03-18-00, 02:50 PM
I've been trying to run a Quake2 server, and although I was successful at doing it, players tell me that ALTHOUGH THE NETGRAPH LOOKS GREAT, THE GAME IS JUMPY, UNSMOOTH, AND THE PING JUMPS ALOT.

Here's my computer/ISP spec:
Pentium III 450
256 meg SDRAM
Windows 98 Second Edition
Shaw@home cable internet provider (in Toronto)
3Com PCI network card
Diamond Viper Ultra Riva TNT2 32 Meg Video Card

Now, when I PLAY the game as a CLIENT, it's GREAT. It's smooth, good framerate, look pings. But, when I run a server (dedicated of course), it's jumpy and unsmooth. Also, I don't know if this is important, but when I try to type commands in the Quake2 server console, I get delays in the appearance of alphabets (the delay is less than half a second, but still obvious).

I don't know what's wrong with my server...I've talked to people who ran server on Shaw@home connection and on Windows 98 and their computer is only Pentium 2, and they say their connection is great...

Note that I've performed all the tweaks for Cable Modem and Windows 98 as suggested on this site.

Bouncer
03-19-00, 05:40 AM
Are you letting windows manage virtual memory?

If so, disable it and use a 200 meg min/max
swapfile.

Make sure you're set to Network Server in Performance >>> file system under windows settings >>> system

Couple of things to try if you haven't already.

Regards,
-Bouncer-


------------------
"Yeah Baby, YEAH!!!"

-=Hitman=-
03-23-00, 10:55 AM
I did all that, and plus all the tweaks listed on this site.

Is it because of the upstream speed of cable modems that results in the jumpiness? This brings me to my next question: How does ADSL compare with cable in terms of running servers? From what I know, even though ADSL doesn't share bandwidth, their upstream speed is STILL capped...is that right?

Brent
03-23-00, 11:06 AM
Yeah your prolly capped at 128kbps upload, all the tweaks in the world can't help that

I tried running a Q3 server with my AT&T@Home and I have the 128kbps cap, I even just ran a 4 person game and it was laggin out everywhere! Your upload bandwith just isn't there for a game server http://www.speedguide.net/ubb/frown.gif

Some Cable providers don't cap as low as 128kbps on the upload so they can host games better. @home is the Worse for capping, they are implementing the 128kbps upload cap all throughout their systems

ADSL can be the same way too, most of the cheapest packages are at 128kbps, but with ADSL you pay for what speeds you want, so if you want to shell out more money for a faster uplaod speed then you do that, of course givin you are within sufficient distance of your Central Office

------------------
a.k.a Borg Drone
Owner/Webmaster
Core Meltdown www.coremeltdown.com (http://www.coremeltdown.com)

Out the 100TX, through the linksys router/switch, down the cable modem, over the Tap, off the bridge, past the node, straight up the gateway, past the head end office....nothing but Net