PDA

View Full Version : Re: Did I crash my WLAN card by starting WZC?



Pavel A.
04-30-08, 05:10 PM
"greatcham" <greatcham@discussions.microsoft.com> wrote in message
news:201871D9-7BD9-431C-801B-94A89C40B20D@microsoft.com...
......................
> Now, when I attempt to "View Available Wireless Networks," I get only an
> error message saying "Windows cannot configure this wireless connection"
> and
> referring me to the Knowledge Base article on starting WZC. Get rid of
> WZC;
> uninstall and reinstall; or try something different?

Ok since you can click on "View Available Wireless Networks",
the WZC is alive and kicking - but your wi-fi adapter is explicitly
configured NOT to work with WZC.
This is a persistent flag in the registry that survives reboot. The vendor
utility could set it.

Regards,
--PA

=?Utf-8?B?Z3JlYXRjaGFt?=
04-30-08, 08:23 PM
Thanks! This helped me look at it more closely. But it's still not working
because

1. WZC is NOT running according to 'Services' (i.e. Run => services.msc),
and the device says it's using the manufacturer's driver (Broadcom). As a
result, it's not possible for me to roll back to the previous driver, because
the Device Manager thinks I never changed.

2. But as you point out, WZC IS running somehow, because when I ask to view
available networks, I still get "Windows cannot configure...." (You're
correct, the device says it's connected.)

You're also correct, this 3-year-old card cannot use WZC at all.

So how do I purge this ghost WZC? When I started it yesterday, I followed
these instructions from the Knowledge Base article
>To start the Wireless Zero Configuration service, follow these steps:
>1. Click Start, click Run, type %SystemRoot%\system32\services.msc /s, and then click OK.
>2. Double-click Wireless Zero Configuration.
>3. In the Startup type list, click Automatic, and then click Apply.
>4. In the Service status area, click Start, and then click OK.

There was a previous step in those instructions that I possibly did not do,
although I doubt that caused trouble:
>If your computer or your wireless network adapter did not come with its own >wireless network software, follow these steps:
>1. Click Start, click Run, type ncpa.cpl, and then click OK.
>2. Click Network Connections.
>3. In Network Connections, click to select your wireless connection, and then >click Change settings of this connection.
>4. On the Wireless Networks tab, click to select the Use Windows to configure >my wireless network settings check box.

When I attempt this now, of course there is no option to "Change settings of
this connection" because WZC is already in control.

Instructions???????


"Pavel A." wrote:

> "greatcham" <greatcham@discussions.microsoft.com> wrote in message
> news:201871D9-7BD9-431C-801B-94A89C40B20D@microsoft.com...
> ......................
> > Now, when I attempt to "View Available Wireless Networks," I get only an
> > error message saying "Windows cannot configure this wireless connection"
> > and
> > referring me to the Knowledge Base article on starting WZC. Get rid of
> > WZC;
> > uninstall and reinstall; or try something different?
>
> Ok since you can click on "View Available Wireless Networks",
> the WZC is alive and kicking - but your wi-fi adapter is explicitly
> configured NOT to work with WZC.
> This is a persistent flag in the registry that survives reboot. The vendor
> utility could set it.
>
> Regards,
> --PA
>
>
>

=?Utf-8?B?Z3JlYXRjaGFt?=
04-30-08, 08:26 PM
PS: just to confirm, I also can't get rid of WZC by going to Advanced
Properties of the connection, because the option "WZC Managed Ethernet" is
already marked "disabled."

Pavel A.
05-01-08, 04:23 AM
"greatcham" <greatcham@discussions.microsoft.com> wrote in message
news:27EF7C99-525F-40FC-A48D-88D535B603B3@microsoft.com...
> PS: just to confirm, I also can't get rid of WZC by going to Advanced
> Properties of the connection, because the option "WZC Managed Ethernet" is
> already marked "disabled."

Now I'm confused... where is this "WZC Managed Ethernet" setting?
Three years old driver definitely may support WZC (perhaps without WPA2
encryption).
Maybe your best option here is calling Dell support.

Regards,
Pavel

Pavel A.
05-01-08, 11:41 AM
"greatcham" <greatcham@discussions.microsoft.com> wrote in message
news:4E4DB65E-3171-40EF-973A-4D8736F8E914@microsoft.com...
> Thanks for asking -- I managed to truly disable WZC now. My Lotus/Meraki
> connection is running fine again and I'm going to stay off my neighbor's!
>
> I was at
> Control Panel -> Network Connections -> this Dell card -> Connection
> Status
> -> Properties -> General -> Configure -> Advanced. This gives a list of
> about 20 properties, starting with
>
> 802.11h
> Afterburner
> Antenna Diversity....
>
> Toward the end of the list there are
> WZC IBSS Channel Number (set by default to 11)
> WZC Managed Ethernet
>
> I found "WZC Managed Ethernet" marked as disabled. Now, I enabled and
> disabled it again. The take-home part for me is that this panel really
> allowed me to change the status, whereas the system Services panel did
> not.
> Thank you so much for helping me look over it.

Glad to be of help. You're welcome.

--PA