PDA

View Full Version : Two PC's on crossover kills WiFi



just bob
04-15-08, 11:46 AM
Connecting two PC's with a crossover cable kills the wifi internet.

When we travel we usually have two laptops connected to the same public WiFi
to check email and surf the web but we also need to share many very large
files between the two laptops. Since both computes have gigabit NIC's I
tried using a crossover cable to link them to get better speeds than over
WiFi.

Both laptops are identical Dell D630 with internal Wifi adapters.

Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
subnet mask is 255.255.255.0 and gateway is themselves.

When I do this the two PC's see each other just fine but the WiFi to the
internet stops working. I believe it is a routing to default gateway issue
but I'm not sure how to cure this. How do you force the PC to use the WiFi
as the default gateway, if that will solve the problem? I have tried using
the route command but even though I craft the command statement exactly as
the help doc says it comes back with an error.

route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10

If you have any ideas how to make this work please let me know!

Thanks,
-Bob

John
04-15-08, 12:12 PM
Set the "interface metric" on your WiFi NIC to be higher than that of wired
NIC.

Read the following:
http://technet2.microsoft.com/windowsserver/en/library/6c7c7ab2-cfdc-4dfe-8560-570d3859f5b11033.mspx
Particularly the following section:

Using multiple gateways

If you have multiple interfaces and you configure a default gateway for each
interface, TCP/IP by default automatically calculates an interface metric
that is based on the speed of the interface. The interface metric becomes
the metric of the default route in the routing table for the configured
default gateway. The interface with the highest speed has the lowest metric
for its default route. The result is that whenever multiple default gateways
are configured on multiple interfaces, the fastest interface will be used to
forward traffic to its default gateway.


"just bob" <kilbyfan@aoldotcom> wrote in message
news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
> Connecting two PC's with a crossover cable kills the wifi internet.
>
> When we travel we usually have two laptops connected to the same public
> WiFi to check email and surf the web but we also need to share many very
> large files between the two laptops. Since both computes have gigabit
> NIC's I tried using a crossover cable to link them to get better speeds
> than over WiFi.
>
> Both laptops are identical Dell D630 with internal Wifi adapters.
>
> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
> subnet mask is 255.255.255.0 and gateway is themselves.
>
> When I do this the two PC's see each other just fine but the WiFi to the
> internet stops working. I believe it is a routing to default gateway issue
> but I'm not sure how to cure this. How do you force the PC to use the WiFi
> as the default gateway, if that will solve the problem? I have tried
> using the route command but even though I craft the command statement
> exactly as the help doc says it comes back with an error.
>
> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>
> If you have any ideas how to make this work please let me know!
>
> Thanks,
> -Bob
>
>
>

John
04-15-08, 12:16 PM
I meant to say "lower" instead of "higher". Lower interface metric has
higher precedence.

"John" <a> wrote in message news:egkrsvxnIHA.5692@TK2MSFTNGP03.phx.gbl...
> Set the "interface metric" on your WiFi NIC to be higher than that of
> wired NIC.
>
> Read the following:
> http://technet2.microsoft.com/windowsserver/en/library/6c7c7ab2-cfdc-4dfe-8560-570d3859f5b11033.mspx
> Particularly the following section:
>
> Using multiple gateways
>
> If you have multiple interfaces and you configure a default gateway for
> each interface, TCP/IP by default automatically calculates an interface
> metric that is based on the speed of the interface. The interface metric
> becomes the metric of the default route in the routing table for the
> configured default gateway. The interface with the highest speed has the
> lowest metric for its default route. The result is that whenever multiple
> default gateways are configured on multiple interfaces, the fastest
> interface will be used to forward traffic to its default gateway.
>
>
> "just bob" <kilbyfan@aoldotcom> wrote in message
> news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
>> Connecting two PC's with a crossover cable kills the wifi internet.
>>
>> When we travel we usually have two laptops connected to the same public
>> WiFi to check email and surf the web but we also need to share many very
>> large files between the two laptops. Since both computes have gigabit
>> NIC's I tried using a crossover cable to link them to get better speeds
>> than over WiFi.
>>
>> Both laptops are identical Dell D630 with internal Wifi adapters.
>>
>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
>> subnet mask is 255.255.255.0 and gateway is themselves.
>>
>> When I do this the two PC's see each other just fine but the WiFi to the
>> internet stops working. I believe it is a routing to default gateway
>> issue but I'm not sure how to cure this. How do you force the PC to use
>> the WiFi as the default gateway, if that will solve the problem? I have
>> tried using the route command but even though I craft the command
>> statement exactly as the help doc says it comes back with an error.
>>
>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>>
>> If you have any ideas how to make this work please let me know!
>>
>> Thanks,
>> -Bob
>>
>>
>>
>
>

Phillip Windell
04-15-08, 05:10 PM
Two choices:

Choice #1 - The easy way
Manually configure The TCP/IP specs of the nics you're using with the
crossover cable.
Make them the same subnet with each other, but different than the wireless
Nics
Leave the Default Gateway blank,..it is used for crossing subnets and they
are not crossing subnets,..it is therefore not supposed to be used,..leave
it blank

Choice #2 - The long annoying and possibly less stabile way
Change the binding order of the nics. Set the WiFi nic as the first. I'll
use XP as the example,..you can translate it to Vista if you run Vista.

Properties of Network Places-->
Advanced from the Top Menu-->
Advanced Settings from the Dropdown Menu-->
Use the side arrows at the Upper box the set the Nic you want to be at the
top

Now it should "favor" that nic if they both have conflicting Default
Gateways

Default Gateways are supposed to be treated as *global* for the whole
machine, hence there should only be one on one nic. This situation is an
example of why a machine should never have more than one Default Gateway
unless the Default Gateway IP#s are in the same subnet and are bound to the
same Nic (used for Dead Gateway Detection, see below). That has been the
Rule for years since TCP/IP was invented,...things haven't changed much.

If it doesn't work after this then you just simply will not be able to
dependably use the Wifi at the same time as using a crossover between the
wired nics. You'll have to pick one or the other at a given moment by
disabling the other.

I hope the links are still good,...they are getting kind of old.

Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP

Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP

Q1157025 - Default Gateway Configuration for Multihomed Computers
http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP

Q175767 - Expected Behavior of Multiple Adapters on Same Network
http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP


--
Phillip Windell
www.wandtv.com

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------

"just bob" <kilbyfan@aoldotcom> wrote in message
news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
> Connecting two PC's with a crossover cable kills the wifi internet.
>
> When we travel we usually have two laptops connected to the same public
> WiFi to check email and surf the web but we also need to share many very
> large files between the two laptops. Since both computes have gigabit
> NIC's I tried using a crossover cable to link them to get better speeds
> than over WiFi.
>
> Both laptops are identical Dell D630 with internal Wifi adapters.
>
> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
> subnet mask is 255.255.255.0 and gateway is themselves.
>
> When I do this the two PC's see each other just fine but the WiFi to the
> internet stops working. I believe it is a routing to default gateway issue
> but I'm not sure how to cure this. How do you force the PC to use the WiFi
> as the default gateway, if that will solve the problem? I have tried
> using the route command but even though I craft the command statement
> exactly as the help doc says it comes back with an error.
>
> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>
> If you have any ideas how to make this work please let me know!
>
> Thanks,
> -Bob
>
>
>

just bob
04-15-08, 06:21 PM
Choice 1 worked nice except.... XP will not let me share files.

I can ping each other now and both machines can access the internet, so your
tip worked. I just do not know how to share files between domain members
when they are not on the domain.

Any ideas?

Thanks again!


"Phillip Windell" <philwindell@hotmail.com> wrote in message
news:u$017V0nIHA.2188@TK2MSFTNGP04.phx.gbl...
> Two choices:
>
> Choice #1 - The easy way
> Manually configure The TCP/IP specs of the nics you're using with the
> crossover cable.
> Make them the same subnet with each other, but different than the wireless
> Nics
> Leave the Default Gateway blank,..it is used for crossing subnets and they
> are not crossing subnets,..it is therefore not supposed to be used,..leave
> it blank
>
> Choice #2 - The long annoying and possibly less stabile way
> Change the binding order of the nics. Set the WiFi nic as the first.
> I'll use XP as the example,..you can translate it to Vista if you run
> Vista.
>
> Properties of Network Places-->
> Advanced from the Top Menu-->
> Advanced Settings from the Dropdown Menu-->
> Use the side arrows at the Upper box the set the Nic you want to be at the
> top
>
> Now it should "favor" that nic if they both have conflicting Default
> Gateways
>
> Default Gateways are supposed to be treated as *global* for the whole
> machine, hence there should only be one on one nic. This situation is an
> example of why a machine should never have more than one Default Gateway
> unless the Default Gateway IP#s are in the same subnet and are bound to
> the same Nic (used for Dead Gateway Detection, see below). That has been
> the Rule for years since TCP/IP was invented,...things haven't changed
> much.
>
> If it doesn't work after this then you just simply will not be able to
> dependably use the Wifi at the same time as using a crossover between the
> wired nics. You'll have to pick one or the other at a given moment by
> disabling the other.
>
> I hope the links are still good,...they are getting kind of old.
>
> Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
> http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP
>
> Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
> http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP
>
> Q1157025 - Default Gateway Configuration for Multihomed Computers
> http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP
>
> Q175767 - Expected Behavior of Multiple Adapters on Same Network
> http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP
>
>
> --
> Phillip Windell
> www.wandtv.com
>
> The views expressed, are my own and not those of my employer, or
> Microsoft,
> or anyone else associated with me, including my cats.
> -----------------------------------------------------
>
> "just bob" <kilbyfan@aoldotcom> wrote in message
> news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
>> Connecting two PC's with a crossover cable kills the wifi internet.
>>
>> When we travel we usually have two laptops connected to the same public
>> WiFi to check email and surf the web but we also need to share many very
>> large files between the two laptops. Since both computes have gigabit
>> NIC's I tried using a crossover cable to link them to get better speeds
>> than over WiFi.
>>
>> Both laptops are identical Dell D630 with internal Wifi adapters.
>>
>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
>> subnet mask is 255.255.255.0 and gateway is themselves.
>>
>> When I do this the two PC's see each other just fine but the WiFi to the
>> internet stops working. I believe it is a routing to default gateway
>> issue but I'm not sure how to cure this. How do you force the PC to use
>> the WiFi as the default gateway, if that will solve the problem? I have
>> tried using the route command but even though I craft the command
>> statement exactly as the help doc says it comes back with an error.
>>
>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>>
>> If you have any ideas how to make this work please let me know!
>>
>> Thanks,
>> -Bob
>>
>>
>>
>
>

just bob
04-15-08, 06:37 PM
A few minutes later

Had to create two local admin accounts on each machine to use for
authentication since a DC is not present, added each machine name and IP to
each others hosts file (even ping seems slow without this) and used map
network drive with login with other name. Fairly pathetic but it works
bunch of hoops I had to go through but it does work OK.

Is there an easier way?


"just bob" <kilbyfan@aoldotcom> wrote in message
news:zY-dnW3mz5TCpZjVnZ2dnUVZ_rCtnZ2d@supernews.com...
> Choice 1 worked nice except.... XP will not let me share files.
>
> I can ping each other now and both machines can access the internet, so
> your tip worked. I just do not know how to share files between domain
> members when they are not on the domain.
>
> Any ideas?
>
> Thanks again!
>
>
> "Phillip Windell" <philwindell@hotmail.com> wrote in message
> news:u$017V0nIHA.2188@TK2MSFTNGP04.phx.gbl...
>> Two choices:
>>
>> Choice #1 - The easy way
>> Manually configure The TCP/IP specs of the nics you're using with the
>> crossover cable.
>> Make them the same subnet with each other, but different than the
>> wireless Nics
>> Leave the Default Gateway blank,..it is used for crossing subnets and
>> they are not crossing subnets,..it is therefore not supposed to be
>> used,..leave it blank
>>
>> Choice #2 - The long annoying and possibly less stabile way
>> Change the binding order of the nics. Set the WiFi nic as the first.
>> I'll use XP as the example,..you can translate it to Vista if you run
>> Vista.
>>
>> Properties of Network Places-->
>> Advanced from the Top Menu-->
>> Advanced Settings from the Dropdown Menu-->
>> Use the side arrows at the Upper box the set the Nic you want to be at
>> the top
>>
>> Now it should "favor" that nic if they both have conflicting Default
>> Gateways
>>
>> Default Gateways are supposed to be treated as *global* for the whole
>> machine, hence there should only be one on one nic. This situation is an
>> example of why a machine should never have more than one Default Gateway
>> unless the Default Gateway IP#s are in the same subnet and are bound to
>> the same Nic (used for Dead Gateway Detection, see below). That has been
>> the Rule for years since TCP/IP was invented,...things haven't changed
>> much.
>>
>> If it doesn't work after this then you just simply will not be able to
>> dependably use the Wifi at the same time as using a crossover between the
>> wired nics. You'll have to pick one or the other at a given moment by
>> disabling the other.
>>
>> I hope the links are still good,...they are getting kind of old.
>>
>> Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
>> http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP
>>
>> Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
>> http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP
>>
>> Q1157025 - Default Gateway Configuration for Multihomed Computers
>> http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP
>>
>> Q175767 - Expected Behavior of Multiple Adapters on Same Network
>> http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP
>>
>>
>> --
>> Phillip Windell
>> www.wandtv.com
>>
>> The views expressed, are my own and not those of my employer, or
>> Microsoft,
>> or anyone else associated with me, including my cats.
>> -----------------------------------------------------
>>
>> "just bob" <kilbyfan@aoldotcom> wrote in message
>> news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
>>> Connecting two PC's with a crossover cable kills the wifi internet.
>>>
>>> When we travel we usually have two laptops connected to the same public
>>> WiFi to check email and surf the web but we also need to share many very
>>> large files between the two laptops. Since both computes have gigabit
>>> NIC's I tried using a crossover cable to link them to get better speeds
>>> than over WiFi.
>>>
>>> Both laptops are identical Dell D630 with internal Wifi adapters.
>>>
>>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
>>> subnet mask is 255.255.255.0 and gateway is themselves.
>>>
>>> When I do this the two PC's see each other just fine but the WiFi to the
>>> internet stops working. I believe it is a routing to default gateway
>>> issue but I'm not sure how to cure this. How do you force the PC to use
>>> the WiFi as the default gateway, if that will solve the problem? I have
>>> tried using the route command but even though I craft the command
>>> statement exactly as the help doc says it comes back with an error.
>>>
>>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>>>
>>> If you have any ideas how to make this work please let me know!
>>>
>>> Thanks,
>>> -Bob
>>>
>>>
>>>
>>
>>
>
>

Jack \(MVP-Networking\).
04-15-08, 07:29 PM
Hi
May be this can Help, http://www.netsetman.com/index.php?s=nsm
Jack (MVP-Networking).

"just bob" <kilbyfan@aoldotcom> wrote in message
news:lvadneRMU9m7oZjVnZ2dnUVZ_qelnZ2d@supernews.com...
>A few minutes later
>
> Had to create two local admin accounts on each machine to use for
> authentication since a DC is not present, added each machine name and IP
> to each others hosts file (even ping seems slow without this) and used map
> network drive with login with other name. Fairly pathetic but it works
> bunch of hoops I had to go through but it does work OK.
>
> Is there an easier way?
>
>
> "just bob" <kilbyfan@aoldotcom> wrote in message
> news:zY-dnW3mz5TCpZjVnZ2dnUVZ_rCtnZ2d@supernews.com...
>> Choice 1 worked nice except.... XP will not let me share files.
>>
>> I can ping each other now and both machines can access the internet, so
>> your tip worked. I just do not know how to share files between domain
>> members when they are not on the domain.
>>
>> Any ideas?
>>
>> Thanks again!
>>
>>
>> "Phillip Windell" <philwindell@hotmail.com> wrote in message
>> news:u$017V0nIHA.2188@TK2MSFTNGP04.phx.gbl...
>>> Two choices:
>>>
>>> Choice #1 - The easy way
>>> Manually configure The TCP/IP specs of the nics you're using with the
>>> crossover cable.
>>> Make them the same subnet with each other, but different than the
>>> wireless Nics
>>> Leave the Default Gateway blank,..it is used for crossing subnets and
>>> they are not crossing subnets,..it is therefore not supposed to be
>>> used,..leave it blank
>>>
>>> Choice #2 - The long annoying and possibly less stabile way
>>> Change the binding order of the nics. Set the WiFi nic as the first.
>>> I'll use XP as the example,..you can translate it to Vista if you run
>>> Vista.
>>>
>>> Properties of Network Places-->
>>> Advanced from the Top Menu-->
>>> Advanced Settings from the Dropdown Menu-->
>>> Use the side arrows at the Upper box the set the Nic you want to be at
>>> the top
>>>
>>> Now it should "favor" that nic if they both have conflicting Default
>>> Gateways
>>>
>>> Default Gateways are supposed to be treated as *global* for the whole
>>> machine, hence there should only be one on one nic. This situation is an
>>> example of why a machine should never have more than one Default Gateway
>>> unless the Default Gateway IP#s are in the same subnet and are bound to
>>> the same Nic (used for Dead Gateway Detection, see below). That has been
>>> the Rule for years since TCP/IP was invented,...things haven't changed
>>> much.
>>>
>>> If it doesn't work after this then you just simply will not be able to
>>> dependably use the Wifi at the same time as using a crossover between
>>> the wired nics. You'll have to pick one or the other at a given moment
>>> by disabling the other.
>>>
>>> I hope the links are still good,...they are getting kind of old.
>>>
>>> Q128978 - Dead Gateway Detection in TCP/IP for Windows NT
>>> http://support.microsoft.com/support/kb/articles/Q128/9/78.ASP
>>>
>>> Q171564 - TCP/IP Dead Gateway Detection Algorithm Updated for Windows NT
>>> http://support.microsoft.com/support/kb/articles/Q171/5/64.ASP
>>>
>>> Q1157025 - Default Gateway Configuration for Multihomed Computers
>>> http://support.microsoft.com/support/kb/articles/Q157/0/25.ASP
>>>
>>> Q175767 - Expected Behavior of Multiple Adapters on Same Network
>>> http://support.microsoft.com/support/kb/articles/Q175/7/67.ASP
>>>
>>>
>>> --
>>> Phillip Windell
>>> www.wandtv.com
>>>
>>> The views expressed, are my own and not those of my employer, or
>>> Microsoft,
>>> or anyone else associated with me, including my cats.
>>> -----------------------------------------------------
>>>
>>> "just bob" <kilbyfan@aoldotcom> wrote in message
>>> news:JK2dnd4QmKVzRpnVnZ2dnUVZ_tijnZ2d@supernews.com...
>>>> Connecting two PC's with a crossover cable kills the wifi internet.
>>>>
>>>> When we travel we usually have two laptops connected to the same public
>>>> WiFi to check email and surf the web but we also need to share many
>>>> very large files between the two laptops. Since both computes have
>>>> gigabit NIC's I tried using a crossover cable to link them to get
>>>> better speeds than over WiFi.
>>>>
>>>> Both laptops are identical Dell D630 with internal Wifi adapters.
>>>>
>>>> Laptop-A's GB NIC is assigned 172.16.16.1 and Laptop-B is 172.16.16.2,
>>>> subnet mask is 255.255.255.0 and gateway is themselves.
>>>>
>>>> When I do this the two PC's see each other just fine but the WiFi to
>>>> the internet stops working. I believe it is a routing to default
>>>> gateway issue but I'm not sure how to cure this. How do you force the
>>>> PC to use the WiFi as the default gateway, if that will solve the
>>>> problem? I have tried using the route command but even though I craft
>>>> the command statement exactly as the help doc says it comes back with
>>>> an error.
>>>>
>>>> route add 0.0.0.0 MASK 255.255.0.0 192.168.1.10
>>>>
>>>> If you have any ideas how to make this work please let me know!
>>>>
>>>> Thanks,
>>>> -Bob
>>>>
>>>>
>>>>
>>>
>>>
>>
>>
>
>

Phillip Windell
04-16-08, 10:54 AM
"just bob" <kilbyfan@aoldotcom> wrote in message
news:lvadneRMU9m7oZjVnZ2dnUVZ_qelnZ2d@supernews.com...
> Had to create two local admin accounts on each machine to use for
> authentication since a DC is not present, added each machine name and IP
> to each others hosts file (even ping seems slow without this) and used map
> network drive with login with other name. Fairly pathetic but it works
> bunch of hoops I had to go through but it does work OK.

The "workgroup model" is always "pathetic" to me :-)

See Jack's post. He has the links that will help with that stuff. I got
the networking side of things cleared up,..I'm satisfied with just that.

--
Phillip Windell
www.wandtv.com

The views expressed, are my own and not those of my employer, or Microsoft,
or anyone else associated with me, including my cats.
-----------------------------------------------------