PDA

View Full Version : Vista: How to save favorite WLAN connections?



Axel Dahmen
04-07-08, 05:15 PM
Hi,

although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.

There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?

Any help is quite appreciated.

Axel Dahmen

Barb Bowman
04-08-08, 03:33 AM
in Vista, right click the network icon in the task tray next to the
clock, then Connect to a network.

in network and sharing center, manage wireless networks, delete the
network you are having trouble with, then set it up again and make
sure it is set to start automatically. in manage wireless networks,
move it to the top of the list.

On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
<keentoknow@newsgroup.nospam> wrote:

>Hi,
>
>although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.
>
>There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?
>
>Any help is quite appreciated.
>
>Axel Dahmen
--

Barb Bowman
MS-MVP
http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
http://blogs.digitalmediaphile.com/barb/

Axel Dahmen
04-08-08, 04:21 PM
Thanks, Barb, for answering!

Is it possible to have an icon set up *without* having it set to start automatically. I don't want my computer to connect to any network automatically without my explicit approval. I prefer to have an icon somewhere to connect manually. But I don't want to enter security data all over again.

Your help is quite appreciated.

Best regards,
Axel Dahmen



-------------
"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:gbbmv3h1bv7tht0qc7ortr7cv4ep7oqrfa@4ax.com...
> in Vista, right click the network icon in the task tray next to the
> clock, then Connect to a network.
>
> in network and sharing center, manage wireless networks, delete the
> network you are having trouble with, then set it up again and make
> sure it is set to start automatically. in manage wireless networks,
> move it to the top of the list.
>
> On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
> <keentoknow@newsgroup.nospam> wrote:
>
>>Hi,
>>
>>although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.
>>
>>There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?
>>
>>Any help is quite appreciated.
>>
>>Axel Dahmen
> --
>
> Barb Bowman
> MS-MVP
> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
> http://blogs.digitalmediaphile.com/barb/

Barb Bowman
04-08-08, 04:29 PM
nothing in Windows will do this. at least with icons. when you set
up wireless networks in Vista, there is a check box for start
automatically. if you don't check that, you should be able to
connect from the list, but not from "icons"

On Tue, 8 Apr 2008 23:21:47 +0200, "Axel Dahmen"
<keentoknow@newsgroup.nospam> wrote:

>Thanks, Barb, for answering!
>
>Is it possible to have an icon set up *without* having it set to start automatically. I don't want my computer to connect to any network automatically without my explicit approval. I prefer to have an icon somewhere to connect manually. But I don't want to enter security data all over again.
>
>Your help is quite appreciated.
>
>Best regards,
>Axel Dahmen
>
>
>
>-------------
>"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:gbbmv3h1bv7tht0qc7ortr7cv4ep7oqrfa@4ax.com...
>> in Vista, right click the network icon in the task tray next to the
>> clock, then Connect to a network.
>>
>> in network and sharing center, manage wireless networks, delete the
>> network you are having trouble with, then set it up again and make
>> sure it is set to start automatically. in manage wireless networks,
>> move it to the top of the list.
>>
>> On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
>> <keentoknow@newsgroup.nospam> wrote:
>>
>>>Hi,
>>>
>>>although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.
>>>
>>>There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?
>>>
>>>Any help is quite appreciated.
>>>
>>>Axel Dahmen
>> --
>>
>> Barb Bowman
>> MS-MVP
>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>> http://blogs.digitalmediaphile.com/barb/
--

Barb Bowman
MS-MVP
http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
http://blogs.digitalmediaphile.com/barb/

Axel Dahmen
04-08-08, 07:19 PM
Yes, I can see the list. But it kind of "loses" secured connections.

Imagine there is one, secured, connection "Unknown Network". SSID is hidden, WPA is enabled.

Connecting to it once by double-clicking it, I enter the SSID and the WPA pass phrase. After connecting, when asked to save this connection, I save the connection, but deselect to automatically connect. Then I disconnect from that connection.

Half an hour later I'll try to re-connect to this connection, so I open the "Connect To a Network..." dialog again. But all I see is "Unknown Network" again. I don't see the saved connection anywhere. So I have to re-enter the whole identification data again, which is quite annoying.

Isn't there a way to have the connection stored *including* SSID and WPA pass-phrase, but *without* having it connection automatically? Where would I find such "saved" connection in order to just double-click it?

Thanks again for enlightening me on this!

Regards,
Axel Dahmen




------------------
"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:hronv396csc6mlq63folb02hlrmbhao8c3@4ax.com...
> nothing in Windows will do this. at least with icons. when you set
> up wireless networks in Vista, there is a check box for start
> automatically. if you don't check that, you should be able to
> connect from the list, but not from "icons"
>
> On Tue, 8 Apr 2008 23:21:47 +0200, "Axel Dahmen"
> <keentoknow@newsgroup.nospam> wrote:
>
>>Thanks, Barb, for answering!
>>
>>Is it possible to have an icon set up *without* having it set to start automatically. I don't want my computer to connect to any network automatically without my explicit approval. I prefer to have an icon somewhere to connect manually. But I don't want to enter security data all over again.
>>
>>Your help is quite appreciated.
>>
>>Best regards,
>>Axel Dahmen
>>
>>
>>
>>-------------
>>"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:gbbmv3h1bv7tht0qc7ortr7cv4ep7oqrfa@4ax.com...
>>> in Vista, right click the network icon in the task tray next to the
>>> clock, then Connect to a network.
>>>
>>> in network and sharing center, manage wireless networks, delete the
>>> network you are having trouble with, then set it up again and make
>>> sure it is set to start automatically. in manage wireless networks,
>>> move it to the top of the list.
>>>
>>> On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
>>> <keentoknow@newsgroup.nospam> wrote:
>>>
>>>>Hi,
>>>>
>>>>although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.
>>>>
>>>>There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?
>>>>
>>>>Any help is quite appreciated.
>>>>
>>>>Axel Dahmen
>>> --
>>>
>>> Barb Bowman
>>> MS-MVP
>>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>>> http://blogs.digitalmediaphile.com/barb/
> --
>
> Barb Bowman
> MS-MVP
> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
> http://blogs.digitalmediaphile.com/barb/

Pavel A.
04-08-08, 10:39 PM
"Axel Dahmen" <keentoknow@newsgroup.nospam> wrote in message
news:373F7EB8-D266-4D7F-B633-7B10727D4759@microsoft.com...
> Yes, I can see the list. But it kind of "loses" secured connections.
>
> Imagine there is one, secured, connection "Unknown Network". SSID is
> hidden, WPA is enabled.
>
> Connecting to it once by double-clicking it, I enter the SSID and the WPA
> pass phrase. After connecting, when asked to save this connection, I save
> the connection, but deselect to automatically connect. Then I disconnect
> from that connection.
>
> Half an hour later I'll try to re-connect to this connection, so I open
> the "Connect To a Network..." dialog again. But all I see is "Unknown
> Network" again. I don't see the saved connection anywhere. So I have to
> re-enter the whole identification data again, which is quite annoying.
>
> Isn't there a way to have the connection stored *including* SSID and WPA
> pass-phrase, but *without* having it connection automatically? Where would
> I find such "saved" connection in order to just double-click it?
>
> Thanks again for enlightening me on this!
>
> Regards,
> Axel Dahmen

There is no ready GUI to do this in Vista, but this is possible with
a bit of scripting or coding. The API allows enumeration and activattion of
connection profiles.

Regards,
--PA


> ------------------
> "Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag
> news:hronv396csc6mlq63folb02hlrmbhao8c3@4ax.com...
>> nothing in Windows will do this. at least with icons. when you set
>> up wireless networks in Vista, there is a check box for start
>> automatically. if you don't check that, you should be able to
>> connect from the list, but not from "icons"
>>
>> On Tue, 8 Apr 2008 23:21:47 +0200, "Axel Dahmen"
>> <keentoknow@newsgroup.nospam> wrote:
>>
>>>Thanks, Barb, for answering!
>>>
>>>Is it possible to have an icon set up *without* having it set to start
>>>automatically. I don't want my computer to connect to any network
>>>automatically without my explicit approval. I prefer to have an icon
>>>somewhere to connect manually. But I don't want to enter security data
>>>all over again.
>>>
>>>Your help is quite appreciated.
>>>
>>>Best regards,
>>>Axel Dahmen
>>>
>>>
>>>
>>>-------------
>>>"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag
>>>news:gbbmv3h1bv7tht0qc7ortr7cv4ep7oqrfa@4ax.com...
>>>> in Vista, right click the network icon in the task tray next to the
>>>> clock, then Connect to a network.
>>>>
>>>> in network and sharing center, manage wireless networks, delete the
>>>> network you are having trouble with, then set it up again and make
>>>> sure it is set to start automatically. in manage wireless networks,
>>>> move it to the top of the list.
>>>>
>>>> On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
>>>> <keentoknow@newsgroup.nospam> wrote:
>>>>
>>>>>Hi,
>>>>>
>>>>>although Vista allows me to save a security enabled wireless connection
>>>>>I can't possibly find any place where to search for the corresponding
>>>>>icon to double-click in order to activate that particular connection.
>>>>>
>>>>>There's one more thing I don't understand: I can find a wireless
>>>>>connection I've already connected to in the list of wireless networks.
>>>>>It even displays the SSID I'd previously entered. But when I
>>>>>double-click that entry I'm requested to enter the pass phrase in
>>>>>again. Why? I already did that... - How can I have it just connect?
>>>>>
>>>>>Any help is quite appreciated.
>>>>>
>>>>>Axel Dahmen
>>>> --
>>>>
>>>> Barb Bowman
>>>> MS-MVP
>>>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>>>> http://blogs.digitalmediaphile.com/barb/
>> --
>>
>> Barb Bowman
>> MS-MVP
>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>> http://blogs.digitalmediaphile.com/barb/

Barb Bowman
04-09-08, 03:42 AM
Hiding the SSID really isn't a good security feature and can create
connectivity issues as well. Did you change the SSID from the
default from the factory? Even doing this, you will likely still
have issues.

My advice is to
1. change to a different SSID and turn on broadcast
2. delete the old SSID name from the list
3. right click the network icon, then connect to a network in Vista
4. make sure you do NOT check "start this network automatically"

if you do the above, you will need to right click the network icon
each time, and then the network will show and you can click to
connect to it and it should have saved your credentials (I haven't
tried this --)

What is your concern about automatically connecting to your own
network with a unique SSID?

On Wed, 9 Apr 2008 02:19:19 +0200, "Axel Dahmen"
<keentoknow@newsgroup.nospam> wrote:

>Yes, I can see the list. But it kind of "loses" secured connections.
>
>Imagine there is one, secured, connection "Unknown Network". SSID is hidden, WPA is enabled.
>
>Connecting to it once by double-clicking it, I enter the SSID and the WPA pass phrase. After connecting, when asked to save this connection, I save the connection, but deselect to automatically connect. Then I disconnect from that connection.
>
>Half an hour later I'll try to re-connect to this connection, so I open the "Connect To a Network..." dialog again. But all I see is "Unknown Network" again. I don't see the saved connection anywhere. So I have to re-enter the whole identification data again, which is quite annoying.
>
>Isn't there a way to have the connection stored *including* SSID and WPA pass-phrase, but *without* having it connection automatically? Where would I find such "saved" connection in order to just double-click it?
>
>Thanks again for enlightening me on this!
>
>Regards,
>Axel Dahmen
>
>
>
>
>------------------
>"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:hronv396csc6mlq63folb02hlrmbhao8c3@4ax.com...
>> nothing in Windows will do this. at least with icons. when you set
>> up wireless networks in Vista, there is a check box for start
>> automatically. if you don't check that, you should be able to
>> connect from the list, but not from "icons"
>>
>> On Tue, 8 Apr 2008 23:21:47 +0200, "Axel Dahmen"
>> <keentoknow@newsgroup.nospam> wrote:
>>
>>>Thanks, Barb, for answering!
>>>
>>>Is it possible to have an icon set up *without* having it set to start automatically. I don't want my computer to connect to any network automatically without my explicit approval. I prefer to have an icon somewhere to connect manually. But I don't want to enter security data all over again.
>>>
>>>Your help is quite appreciated.
>>>
>>>Best regards,
>>>Axel Dahmen
>>>
>>>
>>>
>>>-------------
>>>"Barb Bowman" <barb@nospam.com> schrieb im Newsbeitrag news:gbbmv3h1bv7tht0qc7ortr7cv4ep7oqrfa@4ax.com...
>>>> in Vista, right click the network icon in the task tray next to the
>>>> clock, then Connect to a network.
>>>>
>>>> in network and sharing center, manage wireless networks, delete the
>>>> network you are having trouble with, then set it up again and make
>>>> sure it is set to start automatically. in manage wireless networks,
>>>> move it to the top of the list.
>>>>
>>>> On Tue, 8 Apr 2008 00:15:49 +0200, "Axel Dahmen"
>>>> <keentoknow@newsgroup.nospam> wrote:
>>>>
>>>>>Hi,
>>>>>
>>>>>although Vista allows me to save a security enabled wireless connection I can't possibly find any place where to search for the corresponding icon to double-click in order to activate that particular connection.
>>>>>
>>>>>There's one more thing I don't understand: I can find a wireless connection I've already connected to in the list of wireless networks. It even displays the SSID I'd previously entered. But when I double-click that entry I'm requested to enter the pass phrase in again. Why? I already did that... - How can I have it just connect?
>>>>>
>>>>>Any help is quite appreciated.
>>>>>
>>>>>Axel Dahmen
>>>> --
>>>>
>>>> Barb Bowman
>>>> MS-MVP
>>>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>>>> http://blogs.digitalmediaphile.com/barb/
>> --
>>
>> Barb Bowman
>> MS-MVP
>> http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
>> http://blogs.digitalmediaphile.com/barb/
--

Barb Bowman
MS-MVP
http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
http://blogs.digitalmediaphile.com/barb/