View Full Version : WPA on Quickertek(Ralink) card on Mac Powerbook not working

Ted Lee
04-06-08, 04:56 PM
Intriguing problem. Maybe someone can help diagnose it, or tell me
where to look. I have a Quickertek b/g PCMCIA card for wireless on my
Powerbook G4 (the internal Apple Airport is going flakey.) It works
perfectly in normal mode. I can't get it to work in secure (encrypted
WPA) mode. It's not the router's problem -- that does work fine in
WPA with the airport card (I'm close enough right now the flakiness
doesn't matter.) Network status for the port is yellow, "PCI Ethernet
Slot PC Card is currently active. PCI Ethernet Slot PC Card has a
self-assigned IP address and may not be able to connect to the

Network interface (en2) info says link speed 54Mb, link status active
-- 0 packets sent or received, 0 errors

The card's "link" light is green (I believe this means it's connected
fine). The utility for the card says it is connected to the router.

Linksys WRT54G

it is configured using DHCP; when I renew the lease I get
(which has no relation to anything!)

I tried setting the IP address manually to what it's been getting from
DHCP; that didn't help. Running 10.4.11.

I'm afraid I don't expect much help from Quickertek -- they don't even
have the most current software from Ralink, but I'll give them a try.

Ted Lee
Minnetonka, MN

Ted Lee
04-06-08, 06:45 PM
On Apr 6, 4:56*pm, Ted Lee <TMP...@mr.net> wrote:
> Intriguing problem.

Now even more intriguing -- now it's working! I could not possibly
reconstruct what I did, although one of the things I tried was
deliberately entering the wrong password to see what that did, and
cycling power on the card (there's a "radio off/radio on" button in
the "advanced" settings) at one point. very strange! I haven't
tried a complete shut down/ restart cycle, but it has successfully
made it through a sleep/wake cycle, which did require it to re-
initiate the connection.

Ted Lee
Minnetonka, MN