PDA

View Full Version : FIX: Wireless access point on IPcop Blue network



WaxyBreath
01-18-08, 03:59 PM
Thought I would share my struggle with IPcop Blue + WAP config...

Scenario:

I just installed a Blue network on my IPcop (1.4.11) and want to use a
wireless access point (NOT a wireless router. *In general*, think of a
WAP as having only one ethernet port on the back, and router would
have more than one due to also having a router/switch integrated)


Problem:

After connecting everything, enabling DHCP on the blue interface, and
assigning IP's to blue and the WAP device, there is no internet
access. I can ping the blue interface as well as the WAP, but no
external IP's.


Solution:

If only using a WAP on blue, you MUST create a an entry in the Blue
Access menu for *every* POSSIBLE DHCP address that *may* be assigned.
This seems completely counterintuitive with DHCP involved, but that is
just the it must be configured. Here's what I did as an example:

- 1. I reduced the number of DHCP address in the scope to save me time
entering these rules.
- 2. Under Firewall | Blue Access menu, I added EACH POSSIBLE DHCP
address. MAC or IP can be used. Make sure you check the enable box.








For wireless routers, create a subnet behind the wireless router.
Disable DHCP on the blue interface, enable DHCP on the wireless
router, and finally add the IP of the wireless router to the blue
access device

WaxyBreath
01-18-08, 04:02 PM
PLEASE PLEASE PLEASE! Post a reply if this did or did not help. It's
good to know that was time well spent. If you don't have a Google
groups account, then you know what to do...

neto.armando@gmail.com
02-20-08, 07:55 AM
On 18 jan, 19:02, WaxyBreath <WaxyBre...@gmail.com> wrote:
> PLEASE PLEASE PLEASE! Post a reply if this did or did not help. It's
> good to know that was time well spent. If you don't have a Google
> groups account, then you know what to do...

this didn't help me.. but the problem is the same..

IPCOPuser
03-30-08, 11:53 PM
Hi WaxyBreath...after spending a lot of search I found your solution and it worked.
I still don't understand why I have to add all MAC's to access Internet from AP.
my wireless devices gets IP's from DHCP running on blue but can't connect to internet unless I add MAC to blue access.

Any ways ...thanks for your solution.

vainamoinen
06-08-08, 03:59 PM
This solution was a huge help to me. I also reduced the number
of blue ips I allowed on the dhcp page of ipcop and then added
all of the permitted ips to the blue access page. Many thanks to WaxyBreath for the solution, which I could not find elsewhere.

gatessux
09-28-10, 01:28 PM
"For wireless routers, create a subnet behind the wireless router.
Disable DHCP on the blue interface, enable DHCP on the wireless
router, and finally add the IP of the wireless router to the blue
access device"

This worked for me, but I just wanted to add, that it's not required to enable DHCP on the WAN Interface of the router... I added the static IP of the WAN side of my router, and the MAC (just in case)... I finally have a working Blue Interface. I was only adding the LAN assigned DHCP addresses before, it was causing me to pull my hair out...

Thanks Again!

Hanna
02-07-15, 11:57 PM
You might want to move everything into close proximity to each other while setting everything up so that range or too much range is not causing problems.

Not sure your point about cell service, unless that is how you connect to the Internet. Cell and wireless networking are two different beasts.


How great a distance are you trying to reach? You may need to look into directional antennas.

mirora
08-31-16, 01:27 AM
solution u recommend for wireless routers not working for me.

beispiel
02-26-17, 11:00 AM
This worked for me, but I just wanted to add, that it's not required to enable DHCP on the WAN Interface of the router..