View Full Version : Help me Tweak my connection plz! please..

09-16-07, 04:07 AM
Hi guyz! im a noob when it comes to this and im new to this site.

ISP: Globelines
connection: DSL 768kbps
OS: XP sp2
firewall: windows default

SpeedGuide.net TCP Analyzer Results
Tested on: 09.16.2007 04:55
IP address: 222.127.xxx.x

TCP options string: 0204054801010402
MSS: 1352
MTU: 1392
TCP Window: 65535 (NOT multiple of MSS)
RWIN Scaling: 0
Unscaled RWIN : 65535
Reccomended RWINs: 64896, 129792, 259584, 519168
BDP limit (200ms): 2621kbps (328KBytes/s)
BDP limit (500ms): 1049kbps (131KBytes/s)
MTU Discovery: ON
TTL: 108
Timestamps: OFF
IP ToS: 00000000 (0)

I know my MSS And MTU are not set to optimal. I have already log-in to my router and change it to 1500 but it still stay the same.
My biggest problem is when i try to a tracert to any domain.

C:\>tracert www.yahoo.com

1 1ms 1ms 1ms
2 * * * Request timed out.
3 * * * Request timed out.
4 * * * Request timed out.
5 * * * Request timed out.
6 * * * Request timed out.
7 * * * Request timed out.
8 * * * Request timed out.
9 * * * Request timed out.
10 * * * Request timed out.
11 * * * Request timed out.

13-20 always Request timed out.

PLZ help me guyz...... any help would be greatly appreciated. ^^

my speedtest result: my ping is very high.

http://www.speedtest.net/result/184918935.png (http://www.speedtest.net)

09-16-07, 05:32 AM
Is your modem/router Prolink?

The timed out of your tracert is probably due to the firewall in your router blocking ICMP pings. Turn it off and do another tracert.

Your upload speed is rather low.

First scan for possible spyware using:

Ad-Aware 2007
a-Squared Free

09-16-07, 06:28 AM
I have a prolink H9200 router

When i log in into the router, in the SERVICES section then FIREWALL, it has options like:

Blacklist status=enable or disable (disable)
Attack protection=enable or disable (disable)
Dos protection= enable or disable (disable)
Max half open tcp conn=25
Max ICMP conn=25
Max single host conn=75

Is the firewall already turned off?

09-16-07, 06:59 AM
Yes, It is deemed turned off when disabled.

Another member also have the same MTU problem with Prolink and the same ISP. My guess is that the firmware of Prolink has some incompatibility with this ISP's system.

Try the following with TCP Optimizer:

General Settings tab:
Custom settings - check
Modify All Network Adapters - check
network adapter selection - your NIC
MTU 1392
TTL - 64
TCP Receive Window - 64896
MTU Discovery - Yes
Black Hole Detect - No
Selective Acks - Yes
Max Duplicate ACKs - 2
TCP 1323 Options:
Windows Scaling - uncheck
Timestamps - uncheck

Advanced Settings tab:
Max Connections per Server - 10
Max Connections per 1.0 Server - 10
LocalPriority - 1
Host Priority - 1
DNSPriority - 1
NetbtPriority - 1
Lan Browsing speedup - optimized
QoS: NonBestEffortLimit - 0
ToS: DisableUserTOSSetting - 0
ToS: DefaultTOSValue - 80
MaxNegativeCacheTtl - 0
NetFailureCacheTime - 0
NegativeSOACache Time - 0
LAN Request Buffer Size - 32768
Then select "Apply Changes" and reboot to take effect

09-16-07, 07:57 AM
http://www.speedtest.net/result/184948336.png (http://www.speedtest.net)

http://www.speedtest.net/result/184948698.png (http://www.speedtest.net)

my results are varies greatly. First 400kbps to 120kbps to 800kbps(wow) then to 600kbps
http://www.speedtest.net/result/184949373.png (http://www.speedtest.net)

the ping time is always 999 though. Is it normal to have that ping?

09-16-07, 08:43 AM
No. It is not normal to have high ping to a server that is within 50 miles from you.

But high ping time results only in slow speed and not fluctuating speed.

Fluctuating speed is a sign that your modem is being affected by electromagnetic interference - like placing a magnet next to your hard disk.

09-16-07, 09:32 AM
the router/modem was placed above the cpu. I recently transferred it away from electrical devices. My ping time reduces dramatically.

http://www.speedtest.net/result/184962850.png (http://www.speedtest.net)

http://www.speedtest.net/result/184965048.png (http://www.speedtest.net)

As i tried another tracer it says

1 2ms 1ms no resources.

Is my isp blocking something or is it my router?

09-16-07, 10:35 AM
Yes, your firewall in the router is blocking the tracert. Any settings made in the router will only take effect after you save and reboot the router.

Common sources of electromagnetic interference are:

Cordless phone set
Power supply box in the comp tower
Router, if it is a separate unit
Coiled up signal or power supply cables

09-16-07, 12:35 PM
Thanks for the time and help!