PDA

View Full Version : VPN problems with Linksys WRT300N .. but WRT54GS works!



Aloke Prasad
07-03-07, 06:14 PM
My trusty BEFSR41 failed after many years of service (it was unable to
get IP address lease from the cable modem). I purchased a WRT300N,
figuring that I might use the Wifi feature in the future, even though I
don't have any wireless devices right now.

So, I install the new router, change my password, disable the Wireless
features, verify that the VPN passthrough are enabled. My 2 PC's
(running XP Pro) in the LAN can access the internet just fine .. until I
initiate VPN (Cisco client) on the PC I use for work. As soon as that
VPN is established, I lose all connectivity on that PC. I cannot ping
any devices at work or on the internet. I even disabled the firewall
features on the router, but to no avail. All functionality was restored
when I disconnected from the VPN.

I returned that router and installed a WRT54GS. Everything, including
VPN worked right off the bat (I changed the password and disabled
wireless on this as well.). Again, VPN passthrough (all 3 protocols)
was enabled (by default) in both routers.

I can only conclude that there is some bug in the WRT300N firmware.

The hardware and firmware versions of my devices were:

WRT300N: ver 1.1 Firmware 1.51.2 dated 6/4/07
WRT54GS: ver 7.0 Firmware 7.50.0 dated 3/20/07

Any ideas, comments?

LWMillholland Sr
07-23-07, 11:07 AM
My trusty BEFSR41 failed after many years of service (it was unable to
get IP address lease from the cable modem). I purchased a WRT300N,
figuring that I might use the Wifi feature in the future, even though I
don't have any wireless devices right now.

So, I install the new router, change my password, disable the Wireless
features, verify that the VPN passthrough are enabled. My 2 PC's
(running XP Pro) in the LAN can access the internet just fine .. until I
initiate VPN (Cisco client) on the PC I use for work. As soon as that
VPN is established, I lose all connectivity on that PC. I cannot ping
any devices at work or on the internet. I even disabled the firewall
features on the router, but to no avail. All functionality was restored
when I disconnected from the VPN.

I returned that router and installed a WRT54GS. Everything, including
VPN worked right off the bat (I changed the password and disabled
wireless on this as well.). Again, VPN passthrough (all 3 protocols)
was enabled (by default) in both routers.

I can only conclude that there is some bug in the WRT300N firmware.

The hardware and firmware versions of my devices were:

WRT300N: ver 1.1 Firmware 1.51.2 dated 6/4/07
WRT54GS: ver 7.0 Firmware 7.50.0 dated 3/20/07

Any ideas, comments?

I just removed a Linksys WRT54GS that was working with my Sonicwall software. I also used some Terminal Server software to access my office server. I replaced the router (Gateway setting) running on Comcast Cable, with the Linksys WRT300N, Version 1.0 and updated the firmware to Version 1.1. So far nothing I have done has allowed me to VPN to my office. I have spent at least 6 hours working with the Linksys Chat Line and I'm no closer to solving the problem than when I started. The last contact I had with them, they assured me that the problem is not the WRT300N, but if I connect direct to the modem it goes straight through. It also goes straight through with the WRT54GS. I think it is safe to say that there is a setting in the router that needs to be changed. I spent a good deal of time pouring over their web site before I contacted them and did not find any reference information that fit this problem. Most of the time that I was in contact with their India personel was spent just trying to get them to understand the problem.

I am sorry I don't have an answer for the problem yet, but I'm like a bull dog with a bone, and I will get the answer. When I do I'll post it here so anyone else having this problem can see the solution.

tuxillo
09-05-07, 07:39 AM
I just removed a Linksys WRT54GS that was working with my Sonicwall software. I also used some Terminal Server software to access my office server. I replaced the router (Gateway setting) running on Comcast Cable, with the Linksys WRT300N, Version 1.0 and updated the firmware to Version 1.1. So far nothing I have done has allowed me to VPN to my office. I have spent at least 6 hours working with the Linksys Chat Line and I'm no closer to solving the problem than when I started. The last contact I had with them, they assured me that the problem is not the WRT300N, but if I connect direct to the modem it goes straight through. It also goes straight through with the WRT54GS. I think it is safe to say that there is a setting in the router that needs to be changed. I spent a good deal of time pouring over their web site before I contacted them and did not find any reference information that fit this problem. Most of the time that I was in contact with their India personel was spent just trying to get them to understand the problem.

I am sorry I don't have an answer for the problem yet, but I'm like a bull dog with a bone, and I will get the answer. When I do I'll post it here so anyone else having this problem can see the solution.

I've been spent this morning a couple of hours trying to get my netscreen VPN connection working with this router. i can successfully authenticate on the VPN but I did not receive any traffic on the virtual interface.
Have you actually fixed this problem with your WRT300N?

KiwiCookie
03-19-08, 07:13 PM
Fix for this (follow all the instructions!)


- Upgrade firmware the Linksys WRT300n router to v 2.0.20 (some fixes for vpn: L2TP, IPSEC…)
this is for all European versions of the router

http://www-uk.linksys.com/servlet/Satellite?c=L_Download_C2&childpagename=UK%2FLayout&cid=1129319258422&packedargs=sku%3D1150491114466&pagename=Linksys%2FCommon%2FVisitorWrapper&lid=5842214507B03

- Activate vpn passtrough for the 3 vpn protocols

- In QOS configuration: disable "No Acknowledgment" feature!! Very important, this was the most important reason why it failed.

- Explicitly open the network ports: 500, 4500 and 10000
(used for IPSEC and NAT traversal.
Do this under Port Range Triggering just give each entry a different name, and use the same value for each field, e.g:
ipsec 500 500 500 500
ipsec2 4500 4500 4500 4500
ipsec3 10000 10000 10000 10000
and make sure the Enabled box is checked.

- Do NOT configure port forwarding of the above ports to a fixed IP (port forwarding is not the same as Port Range Triggering)

- Firewall can stay enabled

- Anonymous filter enabled

- NAT enabled

GubbenH
10-03-08, 02:54 AM
Thank you KiwiCookie!! Finally solved the problem :-)

AlissonMurphy
11-27-09, 01:07 PM
This is exactly what i was looking for. thank you for the informative post and keep up the good work!

mleet
11-16-10, 11:29 PM
I am having troubles connecting to my VPN through my wireless router. The only way I can get it to connect is if I do a direct connection to my cable modem and completely bypass the wireless router. I have updated the newest firmware version for the E3000. I know the VPN will work because I have connected to other wireless networks without any problems.
Does anyone have any suggestions?