PDA

View Full Version : Helpppp Automotive gurus!



Rainbow
09-14-06, 09:09 PM
Ok My 1995 Chevy K2500 truck with utility body broke down on me and I cant seem to get it going.
Symtoms:

Start the truck up in the am and it runs perfect, after a few miles come to redlight, when I go to pull out it coughs and dies. I try to start it but it just keeps cranking no go. I put the gas pedal to the floor and it starts very low and rough and blows out thick black smoke and smells like raw gas. Shut it back down, start it up with no gas and it starts to idle very rough...step on the gas it clears up and I go. It may run the rest of the day and be fine or it may do that 3 or 4 more times no set pattern. Now its starting to die while driving, same procedure for getting it going again.

I have repaired/replaced the oxygen sensor, map sensor, egr valve, cleaned the iac module, checked the catalytic converter and entire exhaust.
Everytime i think i have it fixed it will run like a champ then out of the blue wham.
It is a 350 throttle body and the engine lite does not come on (and yes the engine lite works)
Any ideas would be greatly appreciated, I have been working on this for about 5 days now :(

HELP!

Chris
09-15-06, 08:21 AM
could be the TPS

Have you checked fuel preasure, may also be the regulator

Rainbow
09-15-06, 04:13 PM
Did check the tps its ok....Did NOT check the fuel pressure...will try that this weekend thanks.

Duzmor
09-16-06, 08:48 AM
Check the Fuel Filter To the Carb

I had a F250 ford Pick-up and it did the same thing - It was the Fuel filter

Duz:) :)

Rainbow
09-19-06, 12:45 PM
After throwing money at it I finally found and repaired it. Thanks for the help.

Oh it was a bad coolant temperature sensor. I guess the computer thought the engine was always cold making it run rich and thus stalling.

ardos666
12-16-06, 03:18 AM
you must chek if there is a place where the water is near of the petrol becouse if the water enter in the petrol it can couse that damage.there must be a membran whitch is broken.ask for this because a lot of cars use the water to get warm the petrol.

mactoman
01-06-07, 09:08 AM
Next time, go to the local auto parts and invest in a 30 or 40$ scan tool to retreive the codes, It will be alot cheaper in the long run then trial and error. If you post the codes, some of us can help you pinpoint the problems.:thumb: