PDA

View Full Version : packet loss unless heavy download



pinegreen
03-03-05, 07:12 AM
I have recently acquired the new EDIMAX BR-6114WG router and it shows an anomalous behaviour, which I believe is a problem with router.

The problem is that the wireless link between the router and the clients is loosing packets, unless a large file is being downloaded in the background. It happens to both a Windows machine with a broadcom card and a linux machine with an intel mini-pci wireless adapter, regardless of whether they are both associated or just one of them is associated. Both of these systems have used wireless connections with other APswithout any problems in the past and thus I believe it is a router problem.

So, if I start a larger ftp download, it proceeds at a normal pace and
ping to 192.168.2.1 (router) suffers no packet loss and ssh to anoter box is flawless. Hence it is not a range problem. As soon as I stop the download, the packet loss to 192.168.2.1 is 25%-50% and ssh to another box suffers from obvious latency problems associated with such a lossy link. If I connect to router by cat5 cable everything works absolutelly fine.

Any suggestion would be much appreciated.

mnosteele52
03-03-05, 07:28 AM
Hi pinegreen :), do you have the latest firmware for your router? Do you have the latest drivers for your wireless cards? Are you using any type of encryption with your wireless?

:D

pinegreen
03-04-05, 04:59 AM
Yep, that did it! I never believed in firmware upgrades ;-), but this time the upgrade for 1.84 to 1.96 made all the difference. Incidentally, I think that the default setting that has changed is the beacon time, which went down from 1000ms to 100ms (but I am not sure!) and the WLAN light changed the pattern of blinking from something like >XXXX.......XXX...X..X< to more uniform blinking.