View Full Version : Problem Connecting to Internet w/ Router

12-23-04, 09:07 PM
I have been having a heck of a time with my home network lately. I set it up and everything was working fine for months. The basic setup is a cable modem going into the internet port of a Linksys BEFSR41_V3 router. The router then feeds my three computers from the ethernet ports of the built in switch.

So about a week ago I tried to do a firmware update on the router. No big deal, everything went fine. Only problem is that after that I couldn't connect to the internet through the router. If I connect the modem directly to my computer I can get internet access without problems. When I connect my computer to the router I can access everything on the network with no problems.

I had a spare router with the older version of the firmware, so I put that back into place. Now everything is just like it was before I started messing around, and I still can't connect. I also have tried powercycling the modem and router to no avail. It seems no matter what I do I can't connect to the internet through the router anymore. I have released and renewed my ip address through the router interface, and using the command line. I am able to ping my ISP's DNS server through the command line through the router. Yet I still can't connect to the internet through the router.

Any help would be greatly appreciated as I have come to a dead end. Thanks.

12-24-04, 07:18 AM
Can you access the web admin page of the router? If so, do you see it obtain any WAN IP on the "Status" tabbed page?

12-24-04, 09:03 AM
Yes, it has the same ip address that my modem has when connected directly to the PC.

12-24-04, 09:08 AM
With the router that isnt working still hooked up
From the command line ping www.google.com
I get an

What do you get?

12-25-04, 02:20 PM
It resolves to the same ip address, but the ping requests all time out. I guess that means that the DNS is working just fine but can't connect for some reason. Strange.

Any other ideas??

Thanks again.

12-25-04, 05:15 PM
Try downgrading the firmware to a version prior to the one you have now. Sounds like it could be a bad upgrade.

12-26-04, 11:32 AM
Yes, it has the same ip address that my modem has when connected directly to the PC.

By chance, would you have Verizon DSL? IIRC, with some of the older modems, you would have to change the IP of the router from to to resolve an IP conflict with the modem.

12-26-04, 03:13 PM
The first thing I tried was downgrading the firmware, but I still get the same problem.

No, it's not Verizon DSL, but I guess changing the IP address couldn't hurt. I will give it a try and let you know if it helps any.

12-26-04, 04:17 PM
Changing the router's IP didn't help me out any. This is really getting me annoyed :mad: :confused:

Could this possibly be a problem with the modem itself? Or is it more likely to be the cable co not giving an IP address to the router? If it is the later I would need to have them re-provision the modem, which they refuse to do for me.

01-01-05, 12:04 PM
This may be a long shot but... Clone the MAC address from the PC that works online into the router. Just look for the MAC CLONE feature in the router set-up page. That way, you fool your ISP into thinking the same PC is hooked up. You should get an IP address then.

01-01-05, 12:48 PM
I had already tried MAC address cloning, and it didn't do me any good. I did solve the problem though, I switched ISP's. I narrowed it down to being a problem with the ISP, or the modem. I tested out the modem and it worked just fine, so it was the ISP. I gave them a call, and they made all kinds of BS about how it was a bad password (no an incorrect password but a BAD password), or that I needed to setup my CABLE modem connection as a DSL connection to get it working. I explained to them why I felt that was wrong, and they just said do it anyway and that was all they would do as far as help.

I got my new ISP service, same cable modem and everything worked great right off the bat. I got it set up as soon as I put in the CD to run the initialization software. My speed doubled too.

Thanks for all the help though, I greatly appreciate it. :thumb:

01-02-05, 02:19 PM
What modem do you have ?? make and model

02-26-06, 02:31 PM
dumb question, but I did this once. Did you reset everything to default values and reset all the settings, or did you just run the upgrade? Another thing it might be a good idea to dump all your settings so you open up the configuration menus with the standard default password and login and THEN re run the firmware upgrade. You probably did all this, but it seems like if you do things in the wrong order it can be the most frustrating. I learned this the hard way.

good luck

02-26-06, 05:57 PM
i need some help,,,i hooked up a linksys wirerless router and card on my comp about a month ago and it worked great know it will not allow me to get on line unless i hook up with my verizon router.i called linksys and they said that my router is not getting the pings the right way.any one know how to fix this...i am new to this stuff......thanks

04-20-07, 01:15 AM
I have the same problem mentioned above with my LinkSys router and the Arris touchstone telephony modem.
The technician did set the modem up with it wired staight into a PC, and it locked onto it (presumably to the MAC address). There is a little recessed button next to the Internet cable connection on the modem that you can press to reset. After that, connecting it up to any computer works - the modem locks on to it until you reset it again.
So, then I hooked my LinkSys router to the modem and reset it. When I logged into my router from my computer, I saw that the IP, Gateway, DNS , etc. on the router were correct (same as they were on the computer when it was hooked straight to the modem).
The router could ping the internet.
My computer was able to ping the router, but
My computer was not able to ping the internet.
The internet requests from my computer are not being broadcast from the router to the modem/internet correctly.

Any other ideas? (I tried cloning the MAC address from the PC that was hooked up to the modem to my router to no avail)