View Full Version : FTP Error Help Needed

11-29-04, 12:15 PM
I'm ruining an FTP Server on Windows XP Pro using ISS v5.1. I've got a LAN using a D-Link 704UP router. Other PC's on the LAN can access the FTP Server, but when I'm at work, I get an error. I've tried using Active and Passive Mode. Both of the get the login screen and connect to the server. When the page tried to get the contents of the folder, I get the following errors in Active mode:
200 Type set to A
500 Invalid PORT Command
500 'LPRT 6,16,0,0,0,0,0,0,0,0,9,4,0,0,0,0,34,113,2,13,47': command not understood

And the following error in Passive Mode:
The operation Timed out

I've forwarded the correct ports to the router as you can see it does log on but why can't I browse the folders. Please help!!!

11-29-04, 01:52 PM
You got at least one of the ports right - ftp uses two, one for commands and one for data. Sounds like you got tcp21 right for the command channel - what does the ftp server use for data?

BTW - I would look at another ftp package. IIS is bad - and 5.1 is old, I believe (security holes) -

11-29-04, 01:57 PM
I'm not sure what port it uses for data. I would would think 20 but I don't really have a way to identify that. I had also tried Ceasar FTP but got the same errors. Is there a good Free FTP server you could recommend.

11-29-04, 04:27 PM
I'd recommend a unix box :)

I have seen folks recommend BulletProof ftp - search the forums here for a list.

Sounds like your problem is the router - you need to get the list of ports used by your ftp server to troubleshoot - have you tried the IIS help files?


11-29-04, 07:01 PM
Found this - http://support.microsoft.com/?id=555022Explains how to configure the data port ranges for IIS.