View Full Version : 7VKML MB and a Code 10 error (WinXP)

11-20-04, 05:55 PM
I'm trying to fix up a friends home PC and I have everything back to normal except for this error. It relates to the Geforce2 MX400 64mb AGP card and WinXP giving me this error:
"This device cannot start" (Code 10).

The only other card on the MB is a Soundblaster Live card which I have moved to the other slots to see if it effects this error - it doesn't. I've even removed the SB card and I still have the same error. Here are the details:

I power on the PC. XP (XP Pro) boots up fine. After I sign on the MB sees that a new card has been installed. This is after I have pulled/reseated the card). It starts to set it up as normal. I get the usual where do you want to load the drivers from msg window and I have let it do it on it's own AND I have tried newer and older driver sets with no change. After the drivers have been installed XP tells me it's good to go. Fine. I can use the log on ID as long as I want BUT, whenever I switch users it reverts back to the above error msg and I have to load the drivers again.
I have had "1" instance of switching users AND the drivers still being there but only 1.
I've tried a 32mb version of the same card with no change. I tried my older Voodoo3 3000 16mb AGP card and the PC won't even boot!
I've been in the BIOS and changed the AGP from 4x all the way down to 1x with no change in the problem.
I've just recently tried the ViaArena "Hyperion" 4 in 1 fix but that didn't do anything but maybe speed up the boot up time.

I'm at a loss here. I've tried everything I know and I even had a friend who knows ALOT more than I do and he even is at a loss.

My other alternative is to go buy a PCI video card and see if that works, but I wanted to try here first before spending the money on something that "may" not work.

Here are the specs on the PC hardware:

VIA KM266 chipset


1. North-bridge: VIA KM266
2. South-bridge: VIA 8235
3. Realtek 8100 10/100Mb LAN chip
4. Sigmatel 9721 AC97 codec (Rev 3.2 and before)
5. Realtek ALC 101AC97 codec chip (Rev 3.3 and later)


1. Supports PC1600/DDR200 or PC2100/DDR266 DDR memory
2. Supports up to 2GB DDR memory
3. 2 DIMMs of 184-pin DDR sockets

Internal I/O Connectors
# 2 x ATA 66/100/133 bus master IDE ports
# 1 x FDD, 2 x HDD and 1 x CD audio input
# IrDA(1x5) and COM2 on board
# GBT standard front panel
# 2 x USB1.1 connectors (support 2 ports by cable)
Expansion Slots

1. 1 x AGP 4x slot
2. 1 x CNR slott
3. 3 x PCI slots support 33MHz and PCI 2.2 compliant

Thanks in Advance! :)

11-26-04, 09:31 AM
The Code 10 error is most often a result of not having the option "Assign IRQ to VGA" enabled in your motherboards system BIOS. Please note: Making changes to your system BIOS can cause your computer to malfunction or become inoperable. If you are unsure how to make BIOS changes, don’t. Seek assistance from your system administrator or technician. If you are familiar with making changes to your BIOS, you may proceed with this section.

To enter the system BIOS for most PC’s, you need to repeatedly click the “F1” or “Del” key on your keyboard as soon as you turn on your computer until it brings you to the system BIOS. If this does not bring you to your system BIOS, consult your motherboard manufacturer or system manufacturer for more information. Once inside of the system BIOS, search for the option “Assign IRQ to VGA”. Check that this option is enabled and then save these settings. Exit the system BIOS and boot back into Windows. The error code should be gone.